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Kaskadni stilovi (CSS – Cascading Style Sheets) 

Stil u HTML-u odnosi se na boju, veličinu, poziciju, poravnanje bilo kog elementa. (Na primer 
boja teksta, bozadine, font, veličina slova, veličina slike, pozicija lejera, udaljenost od vrha itd.) 

Postoji 3 načina da se dodeli stil nekom elementu: 

1. inline – koristeći atribut style unutar početnog taga elementa 
2. internal (unutrašnji) – koristeći element <style> unutar <head> sekcije dokumenta 
3. external (spoljni) – koristeći jedan ili više spoljnih CSS fajlova 

Kada se upotrebi inline stil, navedene osobine važiće samo za taj konretan element. U 
prethodnoj vežbi, veličine, pozicije i boje lejera postavljali smo koristeći ovaj stil: 

 

Vidimo da je stil određen preko atributa style unutar samog elementa. Kada god stil postavljamo 
preko Tag Properties ili CSS Properties panela, Expression Web formira inline stil. 

Međutim, šta ako želimo da iste osobine važe za više elemenata iste vrste na toj stranici? Na 
primer, da više paragrafa budu istog fonta, boje slova i poravnanja.  Da ne bismo više puta 
pisali iste vrednosti i nepotrebno činili kod komplikovanim i nečitljivim, možemo koristiti 
unutrašnji stil i u zaglavlju dokumenta definisati različite stilove koje želimo da primenimo u 
dokumentu. I ovaj stil pojavljuje se u prethodnoj vežbi. Naime, kad god smo selektovali deo 
teksta i promenili font i veličinu slova preko prečica u Common traci alata, Expression Web je 
generisao unutrašnji stil (.autostyle1) pretpostavljajući da nam ista podešavanja mogu zatrebati 
za još neki dao teksta u dokumentu: 

 

Na ovaj način izbegavaju se ponavljanja unutar iste HTML stranice. Međutim, ako pravimo sajt 
sa više stranica, najčešće želimo da sve stranice imaju isti raspored elemenata strane, odnosno 
lejera u kojima je sav sadržaj. Drugim rečima, želimo isti broj lejera sa istim veličinama i 
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pozicijama. Da ne bismo za svaku stranicu kreirali posebno unutrašnje stilove sa istim 
vrednostima, moguće je sve ove stilove zapisati u poseban dokument koji ima ekstenziju .css i 
tako više puta iskoristiti jednom kreirane stilove.  

Međutim, postavlja se pitanje: šta ako isti element ima definisana sva tri stila – u okviru taga 
elementa je jedna vrednost, u okviru zaglavlja druga, a u spoljnom fajlu treća? Stilovi se zovu 
kaskadni upravo zato jer je definisana hijerarhija među njima: prioritet ima inline stil, zatim 
unutrašnji i na kraju spoljni. Ovo je korisno, jer možda želimo da jedna vrednost važi na celom 
sajtu, ali recimo samo na jednoj stranici sajta želimo drugu vrednost, pa u okviru nje na jednom 
elementu treću vrednost. Ukoliko nemamo takav slučaj, moramo se potruditi da određeni 
element na koji primenjujemo spoljni stil nema nikakve vrednosti definisane inline ili unutrašnjim 
stilom. 

U ovoj vežbi napravićemo sajt sa tri stranice koje imaju identične rasporede strane, pa ćemo 
koristiti spoljne stilove.  

Kreiraćemo novi sajt preko Site > New Site > New Empty Site i nazvati ga Hilandar. Zatim 
kreiramo novu HTML stranicu, promenimo naslov u Hilandar početna strana i sačuvamo ga. 
Zatim upišemo opis stranice i ključne reči u File > Properties: 

 

Kreiranje nove CSS strane 

Sa File > New > CSS komandom kreiramo novi css fajl i odmah ga klikom na File > Save 
snimamo pod imenom format.css. 

Sada moramo ovaj fajl da “prikačimo” na našu HTML stranicu kako bismo svaki stil koji upišemo 
u njega mogli na njoj: ponovo selektujemo našu početnu (default.html) i na Apply Styles panelu 
kliknemo Attach Style Sheet. (Ukoliko nemamo panel Apply Styles, dodajemo ga klikom na 
Panels > Apply Styles.) U dijalog prozoru preko Browse dugmeta selektujemo prethodno 
kreiranu format.css stranu: 
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Expression Web će u head sekciji kreirati tag <link> sa adresom fajla format.css. U slučaju rada 
na računarima koje koristi više ljudi koji su radili ovu istu vežbu, treba obratiti pažnju da nismo 
prikačili nečiji tuđi fajl. Adresa fajla treba da glasi samo format.css, bez ikakve putanje pre 
imena, jer to znači da se taj fajl nalazi u istom folderu/sajtu gde i default.html, a to i želimo. 
Ukoliko to nije slučaj, znači da smo prikačili pogrešan fajl i treba iz koda izbrisati sve putanje i 
ostaviti samo format.css, kao na slici: 

 

Najpre ćemo kreirati novi stil za body tag koji će postaviti sve margine na 0. 

Klikom na New Style u okviru panela Apply Styles otvara se sledeći prozor za dijalog: 
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Za selektor ćemo u padajućoj listi izabrati body, jer se margine odnose na celu stranicu. 

Ono što je vrlo važno je da u Define in: obavezno izaberemo Existing style sheet (nikako 
ostaviti Current Page), inače će Expression Web automatski kreirati novi unutrašnji stil i 
vrednosti margina za tag body upisati u zaglavlje dokumenta, dok će format.css ostati prazan. 
Zatim preko Browse dugmeta izaberemo naš format.css. 

Margine se podešavaju u kategoriji Box. Ostavićemo štiklirano Same for all i upisati vrednost 0. 
(Ovde nije potrebno unositi jedinicu mere px) 

Kada kliknemo na OK, taj stil će se pojaviti u panelu Apply Styles:  

 

Ukoliko to nije slučaj, a u fajlu format.css je kreiran odgovarajući kod: 

 

to znači da smo stranici zaboravili da prikačimo format.css ili smo prikačili pogrešan fajl. Treba 
se vratiti na default.html i sa panela Apply Styles izabrati Attach Style Sheet i izabrati 
odgovarajući format.css. 

S druge strane, ukoliko se stil pojavio u Apply Styles, ali je fajl format.css prazan, to znači da 
smo zaboravili da postavimo stil u spoljni fajl (Define in: u prozoru New Style i odabir css fajla 
format.css). Ova greška se malo teže ispravlja, jer se sve druge osobine stila mogu lako 
naknadno menjati (dok smo na html stranici desni klik na stil u panelu Apply Styles, pa klik na 
Modify Style), ali ne i gde će stil biti smešten, pa je jedna opcija da ga izbrišemo (desni klik na 
stil, pa Delete) i napravimo ponovo, a druga da prekopiramo sav tekst između tagova <style> u 
head sekciji html dokumenta na format.css, a zatim izbrišemo ceo taj deo iz zaglavlja, sa sve 
<style> tagovima. U okviru <head> sekcije dokumenta ne treba uopšte da postoji <style> 
element. 

Ukoliko je css fajl prikačen, stil za body će se automatski primeniti, jer je body selektor. 

Sada ćemo na sličan način kreirati raspored strane kao na slici: 
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Ubacićemo 4 lejera i voditi računa da Expression Web nije ubacio neki od lejera jedan u drugi. 
To možemo proveriti na dva načina: ili direktno u kodu – potrebno je da završni tag svakog 
lejera ide pre početnog taga narednog lejera: 

 

Ukoliko nije tako, već su tagovi ugnježđeni jedan u drugi: 

 

treba iseći završni tag spoljnog lejera i prebaciti ga na odgovarajuće mesto (Cut-Paste). 

Drugi način da ovo uradimo je preko panela Layers. Ako je sve kako treba, on će izgledati 
ovako: 

<div id="Zaglavlje"></div> 

<div id="Navigacija"></div> <div id="Sadrzaj"></div> 

<div id="Podnozje"></div> 
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a ukoliko je jedan ugnježđen u drugi, izgledaće ovako: 

 

U tom slučaju moguće je prevući ugnježđeni lejer na dole (Drag&Drop) i on će doći na svoje 
mesto. 

Sve vreme Expression Web vrši formatiranje uz pomoć inline stila preko atributa style. Ako ga 
ne izbrišemo iz taga svakog od lejera, on će imati prioritet, a to ne želimo. Dakle, treba izbrisati 
ceo atribut Style iz taga svakog od lejera: 

 

a zatim za svaki lejer napraviti novi stil koji će biti zapisan u spoljnom css fajlu format.css, na isti 
način kao što smo to uradili za margine taga body. Ono što je drugačije je to što je body 
selektor (ima svoj tag <body>), dok su lejeri svaki za sebe, odnosno ne pravimo stil koji će važiti 
za sve lejere, već za svaki posebno, obraćajući im se po atributu id. Zato ćemo u delu Selector: 
sami ukucati ime lejera ispred kog ide znak #, jer on upravo znači da se ime odnosi na 
odgovarajući id.   

U kategoriji Position obavezno postavljamo position na absolute, a width, height, top i left na 
sledeće vrednosti za svaki od lajera. (Za svaki lejer pravimo novi stil.) 

Dakle, za lejer Zaglavlje postavićemo širinu na 960px, a visinu na 125px. Top i left nećemo 
popunjavati jer oni iznose 0px. Zatim ćemo postaviti boju pozadine (background-color) u 
kategoriji Background na #CCCCCC. (Za svaki lejer postavićemo različitu boju pozadine kako 
bismo videli tačan raspored. Ako sve uradimo kako treba, oni će se složiti u piksel.) 
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Kada pritisnemo dugme OK, taj stil bi trebalo da se pojavi u panelu Apply Styles: 

 

a u format.css sledeći kod: 

 

Sada kreiramo još 3 stila za preostala 3 lejera postavljajući sledeće vrednosti: 
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div (Layer) Zaglavlje Navigacija Sadrzaj Podnozje 

width 960px 150px 810px 960px 

height 125px 840px 840px 100px 

top  125px 125px 965px 

left   150px  

background-
color 

#CCCCCC #999999 #666666 #CCCCCC 

Sve što je sada preostalo je da dodelimo svakom lejeru po jedan stil – selektujemo lejer1 klikom 
na njega u kodu, a zatim kliknemo na stil #Zaglavlje u panelu Apply Styles. Zatim lejer2 i tako 
redom. 

Nakon toga, strana u pretraživaču treba da izgleda otprilike ovako: 
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Ukoliko dolazi do preklapanja, ili je neki od lejera pomeren i ne uklapa se sa ostalima, treba 
proveriti da li je position postavljen na absolute, da nije slučajno vrednost za left postavljena u 
right i da li postoji stil body i da li su margine u njemu postavljene na 0. Ako je sve ovo urađeno 
kako treba, lejeri će se savršeno uklopiti. 

Centriranje strane /sadržaja 

Da bismo centrirali kompletan sadržaj naše stranice u pretraživaču, napravićemo novi div sa 
ID=”Omotac”. Njegov početni tag mora počinjati pre svih ostalih div-ova, dakle odmah iza taga 
body, a završni posle svih ostalih, odmah pre zatvarajućeg body taga, kako bi svi prethodni 
lejeri bili ugnježdeni unutar njega. Za ovo je bolje ne koristiti Toolbox, već otkucati odgovarajući 
kod ručno, a završni tag iseći i prebaciti na kraj: 

 

Za njega ćemo napraviti novi stil #Omotac, pozicionirati ga relativno i postaviti levu i desnu 
marginu na auto vrednost:  

 

Kreiranje rasporeda strane koristeći postojeće stilove 

Pošto već imamo spremljen spoljni CSS fajl, sve što je potrebno da uradimo na drugoj (i 
ostalim, koliko ih ima) stranici našeg sajta je da ubacimo odgovarajući broj lejera, obrišemo stil 
iz njihovih tagova i na Apply Styles panelu kliknemo Attach Style Sheet, kako bismo prikačili 
spoljni fajl sa stilom. Ukoliko direktno u kodu upišemo odgovarajuća imena lejera, stilovi će se 
primeniti automatski. Ako to ne uradimo, potrebno je selektovati lejer po lejer i zatim kliknuti na 
odgovarajući stil u panelu Apply Styles. 

Drugi, lakši način da se ovo uradi – ukoliko nismo ubacili nikakav sadržaj u lejere početne 
stranice – je da izbrišemo sav kod sa nove stranice i tu prekopiramo celokupni kod početne 
stranice, a zatim samo promenimo title (eventuelno i opis i ključne reči preko File > Properties). 

Dakle, sa File > New > HTML napravićemo nove dve stranice  i sačuvati ih pod imenima 
manastir.html (title Manastir) i sveta-gora.html (title Sveta Gora) sa istim rasporedom strane kao 
u početnoj stranici default.html, a zatim na sve tri stranice u lejeru Navigacija napraviti linkove 
ka druge dve i jedan spoljni link O nama koji vodi na sajt Gimnazije „Sveti Sava“. 
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Kreiranje lista 

U zaglavlje početne stranice ubacićemo sliku Hilandar_zaglavlje.jpg, a u sadržaj tekst iz fajla 
Hilandar.docx. Prvi pasus ćemo postaviti da bude naslov h1, drugi h2, a treći, kao i poslednji 
pasus teksta stila italic. 

Na slici Hilandar-IZGLED.png vidimo da je jedan deo teksta u obliku nesortirane liste. 
Odvojićemo taj deo teksta enterima ispred i iza, tako da bude poseban pasus, zatim ćemo ga 
selektovati i kliknuti na prečicu za nesortiranu listu (Bullets) u Common traci alata. Svaku 
stavku ćemo odvojiti enterom od prethodne. Vidimo da je Expression Web generisao kod sa 
listom sa tagom ul (Unordered List) u okviru kog je svaka stavka liste označena tagom li (list 
item). 

 

Korišćenje CSS-a za poravnanje slika 

Ispred pasusa u kome treba da se nalazi slika ubacićemo sliku Hilandar_glavna.jpg. 

Napravićemo novi stil koji će poravnati sliku udesno i napraviti malo razmaka između slike i 
susednog teksta. Pošto stil koji postavlja sliku desno treba da omogući da se može primeniti na 
bilo koju sliku (ili više njih), a ne samo na jednu (preko atributa id) ili na sve (preko selektora 
img), ovaj stil će se primenjivati uz pomoć klasa, tako da može biti korišćen na bilo kom 
elementu dokumenta koji će biti definisan imenom te klase. Svi stilovi za klase počinju tačkom, 
pa ćemo u polju Selector uneti ime .slika-desno. 

U Layout kategoriji New Style dijaloga postavićemo Float na desno (right), a u Box kategoriji 
pod Margin deselektovati Same for all iznad Margin i staviti 10 px za levu marginu (left) i 10 px 
za donju (bottom). 
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Kada je still kreiran, treba ga samo primeniti na sliku koju smo ubacili – kliknućemo na sliku a 
zatim na stil .slika-desno u panelu Apply Styles i slika će se pomeriti udesno. 

Ubacivanje sadržaja u Layer Podnozje 

Otkucati sledeći tekst: Sva prava zadržana ©2010-2014. Dizajn NZ Studio Corp. 

Copyright znak ubaciti uz pomoć komande Insert > Symbol. 

Modifikovaćemo stil za podnožje desnim klikom na #Podnozje u Apply Style panelu i klikom na 
Modify Style. U kategoriji Block postavićemo text-align vrednost na center, a u kategoriji Font 
boju slova na narandžastu. 

NZ Studio Corp tekst istaći sa strong tagom uz pomoć B ikonice. 

Dovršavanje sajta Hilandar uz fino podešavanje 

Da odmaknemo malo tekst od ivice kontejnera, kreiraćemo nove stilove za svaki od selektora p, 
a, h1 i h2 i postaviti padding opcije u kategoriji Box na 10px. 

Umesto kreiranja ovih stilova možemo postaviti i padding na primer za ceo lejer Sadrzaj (po 
10px na levoj i desnoj strani), ali onda moramo smanjiti širinu lejera za 20px. Isto važi i za lejer 
Navigacija u kome su linkovi. 

Pošto font linkova u lejeru Navigacija treba da bude veći, možemo to uraditi na dva načina: 
kako su linkovi jedini tekst u ovom lejeru, možemo prosto modifikovati stil za lejer Navigacija 
tako što ćemo povećati veličinu fonta na 24 px. Opet, kako na sajtu nema drugih linkova osim u 
lejeru navigacija, možemo umesto toga kreirati novi stil sa selektorom a (tag za linkove) i 
postaviti veličinu slova za linkove na 24 px. 

Za Sadržaj ćemo postaviti boju pozadine (background-color) na crnu, a boju fonta (font-color) 
na belu.  

Na kraju obavezno testirati kako stranice izgledaju u pretraživaču i proveriti da li rade svi linkovi. 

 


